in

Harry Potter: Wizards Unite Supported Devices

You can read device requirements and supported devices that you can play Harry Potter: Wizards Unite in this page.

Harrypotterwizardsunite.com

Harry Potter: Wizards Unite is augmented reality supported, that means devices has specific hardware requirements. For example, GPS and location services are necessary to play the game, so unfortunately, Niantic cannot support some of the devices.

Harry Potter: Wizards Unite Supported Devices
Harry Potter: Wizards Unite Supported Devices

Niantic announced, they will use the same game core with Pokemon GO in Harry Potter: Wizards Unite, too, but some of the devices which are compatible with Pokemon GO haven’t be compatible with Wizards Unite yet.

Troubleshooting

Many of our users mentioned a problem with their devices. They’ve gotten the error message “Your device isn’t compatible with this version“. In order to provide a solution to our users, we’ve written an article about that. You can read this article and apply the solution method in order to fix the problem. Then, you will be able to play Wizards Unite if your device has the required features. You can access the article by clicking the link below:

Operating System

Harry Potter: Wizards Unite was published for two operating systems. These are;

  • Android (5.0 or above)
  • IOS (IOS 10.0 or above)

Required Hardware

  • 2 GB Ram (Minimum)
  • 2 GB Storage (Minimum)
  • Internet Connection (Wi-fi, 3G or LTE)
  • GPS and Location Services
  • Gyroscope and compass sensors
  • Camera for AR

Supported – Compatible Devices (Confirmed)

Apple

  • iPhone 5S
  • iPhone SE
  • iPhone 6
  • iPhone 6 Plus
  • iPhone 6s
  • iPhone 6s Plus
  • iPhone 7
  • iPhone 7 Plus
  • iPhone 8
  • iPhone 8 Plus
  • iPhone X
  • iPhone XS
  • iPhone XS Max
  • iPhone XR
  • iPad Air
  • iPad Air Wi-Fi + Cellular
  • iPad mini 2
  • iPad mini 2 Wi-Fi + Cellular
  • iPad Air 2
  • iPad Air 2 Wi-Fi + Cellular
  • iPad mini 3
  • iPad mini 3 Wi-Fi + Cellular
  • iPad mini 4
  • iPad mini 4 Wi-Fi + Cellular
  • 12.9-inch iPad Pro
  • 12.9-inch iPad Pro Wi-Fi + Cellular
  • 9.7-inch iPad Pro
  • 9.7-inch iPad Pro Wi-Fi + Cellular
  • iPad Wi-Fi (5th generation)
  • iPad Wi-Fi + Cellular (5th generation)
  • 12.9-inch iPad Pro (2nd generation)
  • 12.9-inch iPad Pro Wi‑Fi + Cellular (2nd generation)
  • 10.5-inch iPad Pro
  • 10.5-inch iPad Pro Wi‑Fi + Cellular
  • iPad (6th generation)
  • iPad Wi-Fi + Cellular (6th generation)
  • iPad Pro (11-inch)
  • iPad Pro (11-inch) Wi-Fi + Cellular
  • iPad Pro (12.9-inch) (3rd generation)
  • iPad Pro (12.9-inch) (3rd generation) Wi-Fi + Cellular
  • iPad mini (5th generation)
  • iPad mini (5th generation) Wi-Fi + Cellular
  • iPad Air (3rd generation)
  • iPad Air (3rd generation) Wi-Fi + Cellular
  • iPod touch

Asus

  • Asus Zenfone 3
  • Asus Zenfone Max Pro M1

Huawei

  • Huawei P10
  • Huawei P20 Lite
  • Huawei Honor 8

OnePlus

  • OnePlus 3T+
  • OnePlus 3 (wia APK )

LG

  • LG G6+

Motorola

  • Moto G6

Pixel

  • Pixel 1XL
  • Pixel 2
  • Pixel 3XL

Pocophone

  • Pocophone F1

Samsung

  • Samsung Note 9
  • Samsung Galaxy A3
  • Samsung J5 (2017)
  • Samsung Galaxy J7 Pro
  • Samsung Galaxy S6
  • Samsung Galaxy S7
  • Samsung Galaxy S8
  • Samsung Galaxy S9
  • Samsung Galaxy S10
  • Samsung Tab A (2017)

Sony

  • Sony Xperia Z3

Unsupported – Not Compatible Devices (Confirmed)

Alcatel

  • Alcatel 5041C
  • Alcatel A30 Tablet
  • Alcatel One Touch Idol 3 (5.5)

Huawei

  • Huawei Nova 2i
  • Huawei P9 Lite
  • Huawei Mate 10 Lite
  • Huawei Y6 2018

HTC

  • HTC One

LG

  • LG Aristo
  • LG X Charge
  • LG Phoenix 4
  • LG Fortune 2
  • LG K10
  • LG K20
  • LG K20 Plus
  • LG K30
  • LG Stylo 2 V
  • LG Stylo 4

Motorola

  • Moto G 4 Play (Android 7.1.1)
  • Moto G Turbo Edition
  • Motorola Droid Turbo 2
  • Motorola Zoom Tablet

Samsung

  • Samsung Galaxy Holo
  • Samsung Galaxy S3
  • Samsung Galaxy S4
  • Samsung Galaxy S4 Mini
  • Samsung Galaxy S5
  • Samsung Galaxy S5 Neo
  • Samsung Galaxy Gran Duos Prime TV
  • Samsung Galaxy J3
  • Samsung Galaxy J5 (except 2017)
  • Samsung Galaxy J6
  • Samsung Galaxy J7 (2016, Android 8.1.0)
  • Samsung G4 Plus
  • Samsung J7 Star
  • Samsung Galaxy ON5

Sony

  • Sony Xperia E5
  • Sony Xperia XA1

Xiaomi

  • Xiaomi 5A
  • Xiaomi Redmi 6

ZTE

  • ZTE Blade z Max

Notice!

To get news and updates of Wizards Unite follow our social media accounts.

Michael Shaner

Written by Michael Shaner

Hi, geeks! I am Michael Shaner and I am potterhead like you. Follow me for Harry Potter: Wizards Unite and Harry Potter: Hogwarts Mystery rumors, news, tutorials, tips and tricks.

162 Comments

Leave a Reply
  1. I wish they would make it available for more phone’s I can play Pokemon go on my phone but it says that I’m not compatible with this game on my phone

    • I also have a Huawei mate 10 lite and when I search for Wizards Unite I see the message that it isn’t compatible so…

    • I’m sorry. When I wrote the reply, Wizards Unite had not published yet, and the features of Huawei Mate 10 Lite were enough for the game. I made a guess by using the information about the features, but I was wrong. The device is not compatible with Wizards Unite, and I put the device to the unsupported devices list. However, I’m sure that it will be compatible with Wizards Unite when the game is released.

  2. How about honor 7 lite (aka 5C)? It says not available for your device, but i should have all the system reuirements…

  3. I’m playing Pokemon Go on my Infocus Turbo 5 but play store says Wizards unite isn’t compatible with my device. Can i hope it’ll be available on my phone too. It has 3GB RAM and runs on Android 7.0

    • Can you try to install Wizards Unite by using APK file? My phone (Samsung Galaxy J7) is not compatible, too, but I installed Wizards Unite by using APK file.

  4. i also get the message in google play, that my device is incompatible (samsung s8+),
    it doesn’t even allow me to install it to actually try, if it will work anyway…

    • Yes, it is not compatible with your phone, but we are sure that Wizards Unite will be compatible with your phone soon. It is Beta now. When it is released, most of the devices will be compatible with it.

    • We don’t have clear information about the device, but it may be not compatible. When we learn about anything about that, we will reply to your comment. Keep in touch.

  5. What about the Samsung Galaxy Note series? They aren’t listed here. I’m using a Galaxy Note 5 currently.

    • We created the list by using the information comes from our members and followers. We know Samsung S7 is compatible with Wizards Unite, but we don’t have any information about J8. If you have Samsung J8, you can try to install the game by using Wizards Unite APK file, and you can give the information about that to us.

    • There isn’t any information about Huawei P20, but P20 Lite is compatible. I believe P20 is compatible, too. Even if it is not compatible now, it will certainly be compatible with the game when it is released all over the world.

  6. Hi! I have a Xiaomi Redmi 6. In your list it is no compatible but I installed the game apk and it works. In the play store said my device it is not compatible. So, is it compatible or not? I’m confused.

    • It is not compatible on Google Play, but you can install and play it by using APK file. The reason for this problem is that the Wizards Unite game is Beta. When it is released for everyone, it will be compatible with most of the devices.

  7. Hi! I have a Oppo A83. In your list there is no mention of this set. So please tell me whether my set is compatible or not?

    • It seems that has enough hardware to run Wizards Unite, but it may be incompatible with the game for Beta. I believe your phone will be compatible with Wizards Unite when it is released.

  8. I have a Xiaomi Redmi Note 3 Pro SE.
    Play store said it is compatible with my phone, let me download and install it today. Game launched and started the tutorial, but when I got to the part where it opened my camera, a popup opened and said “Your device is not compatible”, and the game shut down. Now the game won’t even get past the first loading screen before saying “your device is not compatible”.

    • Its features are compatible with Wizards Unite, but Samsung A5’s release date is 2017, so it might not compatible with the game now. However, don’t worry! Samsung A5 will be compatible with the game when the game is released.

  9. Okay so phones on the Unsupported list aren’t compatible at the moment, but does that mean the won’t be compatible when the game officialy comes out? I have a Huawei P9 Lite

    • Don’t worry. Devices on the unsupported list aren’t compatible with “Wizards Unite” now, but most of the devices will be compatible when the game is released.

    • The features of Samsung J7 Top is enough for Wizards Unite, but it may be incompatible with the beta version of Wizards Unite. However, the device will be compatible with Wizards Unite when it is released.

    • We don’t have any information about Huawei P20 Pro, but its features are enough for Wizards Unite. Even if Wizards Unite Beta doesn’t work on Huawei P20 Pro, it will be work when the game is released.

  10. Hi I have a Sony Xperia z2 and z5 Im already registered (did it using my z2) but unable to find anything in the playstore on my z5.

  11. why is it not compatible with samsumg galaxy j7 (2016) ;-;
    I wanna play this app so much, just like Pokemon GO

  12. No Nexus phones appear on either supported/not supported list….. When I try to pre-register, I’m told my device isn’t compatible :/

    • Even if your Nexus device is not supported by “Wizards Unite” now, depends on the features of your phone, when the game is released the game will probably work on your phone. What is the features of your Nexus phone?

  13. I have a Galaxy S10 and the Galaxy Store says my phone is not compatible and thus can’t pre-register from there. But was able to do so on the Google Play Store.

  14. I’m not sure what the story is but the Google Play store says that it’s not compatible with my Nexus 6p. Despite meeting the requirements and being able to play Pogo and Ingress Prime. Google play store also says that my previous two devices HTC One M7 and M8 are compatible, yet I know they have difficulties playing Prime and Pogo.

  15. I think it might be a google play store bug which is saying my device is incompatible, as I side loaded the above APK and it installed without issues, but got the message that the application was out of date and needed to be updated which took me to the play store to say that it was incompatible. ARG!

  16. I’m hoping to play this and the phone I’m hoping to use is Samsung galaxy note and have met the requirements but Google play is saying it’s no longer compatible with your device

  17. Will it work in a MOTOROLA MOTO E 4? I think it has the ram. It definietky has the storage!

  18. I don’t see my Umidigi One Pro listed on either list, but my phone has all the requirements, so I should be OK, I hope.

  19. I see LG stylo 2 V or something. I currently have LG Stylo 4. I also have the incompatible device message.

  20. I was registered with my phone and now it unregistered me and says my device isn’t compatible anymore. I have a LG k20 plus and it was registered even developer emailed me saying my phone will work when I emailed them but now I can never play Harry Potter wizards unite unless I buy a new $200 to $300 dollar phone. Ilme anfmd my little brother waited months to play this and you guys jus Shattered our hopes.

    • I’m sorry about that, but the email might be right. We don’t have any other way in order to play Wizards Unite. If the publisher says that your device is not compatible, we can’t change that.

    • Yes, it is true, but your device may be compatible with Wizards Unite when it is released. However, I’m not sure about that. Even if your device has all the device requirements, the game might not be compatible with your device because your device is old.

  21. Im in Australia and Google play keeps saying that this game is not available in my country why is that

  22. I have a LG g stylo 4, and it meets the requirements. Why isn’t it supported? I have been waiting for months for this game.

    • We don’t know why it is not supported. We just know some information given by developers. Wizards Unite is in the beta program now. I believe a lot of devices not supported might be supported when it is released.

    • We don’t have any feedback about Mate 20 Lite for the beta version of Wizards Unite. However, it is ok for the required features. I think Mate 20 Lite will be compatible with Wizards Unite.

  23. Samsung galaxy S5 is not compatible with this game. I noticed you don’t have s5 on either list but my son has tried to download it only to find his device isn’t compatible.

  24. Hey guys!

    I have a Samsung Galaxy A3 2017 – checks out for all of the criteria, but my Google Play says it is still not supported.
    What else could be the reason for this?

    • Wizards Unite is in the beta program now. I think the reason is that. When the game is released, Samsung Galaxy A3 2017 will probably be compatible with the game.

    • We’ve created the list by using the feedbacks sent by our users. Galaxy S10 is compatible, but we don’t have any information about S10+. S10 and S10+ both have similar features, so I believe they are both compatible with Wizards Unite.

  25. Hello. I just want to know why this game isn’t compatible with Samsung j6? I really want this app and I preregistered months ago.

  26. So it’s not compatible with the Samsung Galaxy J7 V? Well, it’s just another way for that company to force me to play that cr*ppy Pokemon game!

    • Samsung Galaxy J7 has the required features. Even if it is not compatible now, it will probably be compatible with Wizards Unite when the game is released.

  27. I was able to pre register when it all began but now it says it’s not compatiable. I have a Samsung J7 Sky pro

  28. I was registered with my phone and now it unregistered me and says my device isn’t compatible anymore.

    I have a Xiaomi Redmi Note 5 and Note 7

  29. Will more phones be able to have access in the future? I have Samsung Galaxy J7 (2016, Android 8.1.0).

    Thank you

  30. I have a samsung J3 and it says it’s not compatible though I can play Pokemon Go, Jurassive Alive, Ingress etc. Just makes no sense to me. Though Hogwarts Mystery isn’t compatbile either. Wish I could afford a better phone :'(

  31. Why is this game not compatible with my ZTE Blade zMax? I can play Pokemon Go with no issues.

  32. When will Harry potter Wizards unite be available in the US . I am a big Harry potter fan and i always get excited when ever i hear about anything Harry potter related ,

  33. It will be compatible with Huawei P20? On the play store it show me “Pre-registered” Still… What does it mean?

  34. Alcatel 5041c not compatible – message received is: This item cannot be installed in your devices country.

  35. My daughter is unhappy that her Samsung S5Neo isn’t compatible, yet she can play Pokemon Go with no concerns.

    Does anyone know if there will be an update to allow more phones to play?

  36. It works on Samsung Tab A (2017) (that’s a tablet, Wi-Fi only, i.e. needs to be hotspotted), but only if installed from a downloaded APK (2.0.1).

    PS. On this page, when you leave a comment it has a note that for some strange reason shows in Turkish: “Beni haber bültenine kaydet”, which essentially means to subscribe to a newsletter, and which is checked by default. This combination is not nice: most people wouldn’t bother checking the translation.

    • Further info on Samsung Tab A 2017:
      1. The tablet is much slower to load the modules than, say a powerful phone. So, it is not the greatest experience, but my kid enjoys it nevertheless.
      2. Google Play thinks that it is not compatible. So, updates need to be side-loaded (APK downloaded and installed locally), but that works smoothly.
      3. The only thing that doesn’t work on Samsung Tab A (2017) is using portkeys: The tablet lacks orientation sensor, so that module doesn’t work. We have to log out on the tablet, log in temporarily on a different “supported” phone and use the portkey there.

      I suspect a similar situation would be with many “budget” phones that don’t have an orientation sensor. And that’s probably why Niantic marks them as “not compatible”.

  37. Do you know if they are going to update the compatibility of the other phones? My LG aristo 3 plays POGO just fine but not this 🙁

  38. My Moto G6 Play gets the incompatible message. Brand new phone I bought last month running on Android 8.0.0 with 5G of space.

  39. The APK works on the J8 you just can’t install it from the store it gives a generic error about not being able to install

  40. I have a j6 and it’s not on the supported devices or play store.. but Is working fine on the galaxy store, problem solved, try this first.

Leave a Reply

Your email address will not be published. Required fields are marked *

Unknown (Question Mark)

Harry Potter: Wizards Unite Android APK Download